Download apk 1.07 free for Android smartphone

25 Sep

Posted by Dietitians of Canada in Health & Fitness | Sept. 25, 2015 | 20 Comments

Apk file size: 21.0 MB

Use eaTracker to check your food and activity choices, analyze your recipes and plan your meals. Sign up to set goals and track your progress.

Dietitians of Canada part of our Health & Fitness and have average installs from 5000 to 10000. Last Update Sept. 25, 2015. Google play rating is 45.3659. Current verison is 1.07. Actual size 21.0 MB.

Download eatracker-ca.apk 21.0 MB


Phoebe Lau

Lags a lot whenever I try to add foods. Needs to have the nutrition tab with graphs.

Shirley McKenzie

Crashed Crashed while logging in

Bonita Hatcher

No net carb count Defeats the point of carb tracking. No means of inputting step tracker data from my pedometer app. This app is a copy of what's already out there and still doesn't do it better.

Melanie Yee

Not functional I can't add any food or activities. I was finally able to create an account as my email was finally recognized thanks to the bug fix but I can't add anything. I search, nothing comes up and I can't manually add anything. I was thinking this app would be beneficial (since it's Canadian) after seeing it on global news but I think I will stick with "my fitness pal" . (it at least functions and has a huge food database)

Alim Fakirani

Can't sign up Keeps asking to enter valid email after having entered a valid email

Leanna Graham

Can't sign up This was just on the news but it doesn't work

Kathie Paddock

So far, no good. Can't sign up! Trying to do so by entering my email and a password and it keeps saying "valid email address required". I keep checking and its fine. Fix this bug so I can use the app please!

Joanne Tan

Keeps crashing and won't let me log in Useless crap I had to use the website at some points which I couldn't access either. Thanks for helping me fail my health class.


No results?!! The first things I tried to look for were dark lager, oatmeal stout, and chocolate Porter. Because of these different ingredients in these beers, they have different calorie counts. But none of these showed up as having any sort of results on the search page. The only thing I could find was "beer", nondescript and vague. That's f******* useless. Back to MFP

Lynn Hooper

Problematic from the get go I was excited to try this app. However it was problematic to sign up on my Android phone running the most recent lollipop version. Took me 3 tries. Also, there is a privacy statement that pops up, but nowhere to indicate OK or continue past that. Finally I was able to log on, and started to update my profile when the app crashed. I went nowhere fast. So I wasn't even able to try out this app at all. How disappointing. Try an app that works well like Noom for one.

Nathan Lemanski

It crashes a lot And it won't let me add foods I've eaten on the app, all I can do is look at my progress

Carrie Holtom

Didn't even get to try it out, crashed during the sign up process!

Veronica Klym

Crashes Crashes too much, needs to be fixed or its just useless. The idea is awesom but the app is terrible, if you want people to be healthy put an effort into your app.

Andrew Malcolmson

Like others have said, crashes so often it's not usable. Graphically it looks like not much effort was put into designing this app in the first place.

Ari Varsa

Crap Could not even log in, after signing up online.

Anastasia Hensel

The app won't let me search for any foods. I put in a food, press the search key, wait, and nothing shows up. I don't see how I could possibly be doing it wrong. Kind of unfortunate because we use a page that links to this app to help promote a healthy lifestyle to patients who are having heart surgeries!

Carrie Edmeades

Not able to log in...says have to accept terms...but can't find a link or button to push

Cheryl Kinkaid

New update not working Won't let me sign in and browser app isn't working either.

Margaret Russell

Kept saying that someone was hacking into it.

Not functional. Trying to analyse a recipe. Can't seem to add ingredients. Deleted app.

Leave A Comment